USB Mouse Hangs on Startup

Since I can’t find this anywhere else on the net and just sort of stumbled on it, I thought I’d post how I got my Logitech USB Optical Mouse (Red) to work with Windows XP.

My Logitech USB Mouse (Red) is connected to my LG 915FT+ Monitor’s built in hub. The monitor is then connected to my computer.

When I connected the mouse directly to a USB port on the case, it was recognized on startup and I had no problems. Well, that would have been OK but I knew this setup worked fine in Windows 98 and I didn’t want to think Microsoft would change functionality. ;)

I started poking around on the net again and stumbled across a KB article which described issues revolving around USB devices not working after returning from standby or hibernate modes. It said that you should turn off power management for the USB ports. I decided to see if that would fix my problem. First I went straight for the USB Hub on the Monitor but it has no power options. Since I don’t have any of my other USB ports used (everything is connected through the Monitor Hub), I looked at the ports. Bingo. They all had power management turned on.

Once I disabled all of the power management, I restarted my system and *finally* I have a mouse on startup. ;)

So, here’s where you have to go to find the options I’m talking about (if you’re using the default Windows XP settings):

Start -> Control Panel -> Printers & Other Hardware

Click on “System” in the menu on the left.

On the new window, click on the Hardware tab and then click on the Device Manager button.

Way down near the bottom (alphabetical order) there should be “Universal Serial Bus Controllers” tree. Expand it.

For each set of USB ports you have, you should have an entry like “USB Root Hub”. Click on them and on the new window, click on the “Power Management” tab. Uncheck the “Allow the computer to turn off this device to save power” option and hit OK.

You probably only need to do this for the port your hub connects to but if you’re not sure, do it for all.

This worked for me and I have no idea if it will work for you but if you’ve stumbled around on the net as long as I have to find this, it’s probably worth a try!

4 thoughts on “USB Mouse Hangs on Startup

  1. Sonny

    Thanks, that worked right away.
    I had 6 USB Hubs showing, and unchecked the box on each of them.

    Reply
  2. DrMelon

    Wow! Finally! I’ve been unplugging and plugging back in various devices for 2 years now! Cheers very much!

    Reply
  3. PO'd

    Phew, here it is. The solution I’ve been looking for for almost a year. Thanks for sharing this!!!!

    Reply

Leave a Reply to Grace Cancel reply